Hatena::Groupprogram

ひとり開発日記。 このページをアンテナに追加 RSSフィード

2009/03/11 (Wed)

Grails 1.1 Released

|  Grails 1.1 Released - ひとり開発日記。 を含むブックマーク はてなブックマーク -  Grails 1.1 Released - ひとり開発日記。

早速入れ替えた。

"Invalid Package declaration in script"

|  "Invalid Package declaration in script" - ひとり開発日記。 を含むブックマーク はてなブックマーク -  "Invalid Package declaration in script" - ひとり開発日記。

EclipseGrails Pluginを入れて、パッケージ・エクスプローラーの上で右クリック→「新規」→「プロジェクト」→「Grails」→「New Grails Project」でサクッとプロジェクトの雛型ができる。

でも、出来たばっかりのプロジェクトって、/(プロジェクト名)/grails-app/conf/spring/resources.groovy にエラー出ちゃうのです…。

Invalid Package declaration in script: C:\(...)\grails-app\conf\spring\resources.groovy 
is not in a source folder matching the package declaration: resources.groovy
grailstest/grails-app/conf/spring 行 0 GroovyFailureMarker

まぁ、ここに解決策が書いてあったんですけど。

  1. パッケージ・エクスプローラー上、プロジェクトのトップで右クリック
  2. プロパティー」→「Groovy Project Properties」を選択
  3. 「Disable Check Package Matches Source Directory」にチェック→OK

http://img216.imagevenue.com/img.php?image=65183_20090311a_122_549lo.jpg

早い話、上のような設定にすればOKでっす。

トラックバック - http://program.g.hatena.ne.jp/halflite/20090311